VULNERABILITY INTELLIGENCE
CVE-2024-31860
CVSS score6.5 MEDIUM
EPSS probability1.39%
CISA KEVNot currently listed
Published2024-04-09
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Description
Improper Input Validation vulnerability in Apache Zeppelin. By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access. This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Weakness classification
- security@apache.org: CWE-22
- nvd@nist.gov: CWE-22
Primary references
- security@apache.org — Issue Tracking, Patch
- security@apache.org — Mailing List, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List
- af854a3a-2127-422b-91ae-364da2661108 — Issue Tracking, Patch
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Vendor Advisory