VULNERABILITY INTELLIGENCE
CVE-2024-31452
CVSS score8.1 HIGH
EPSS probability0.66%
CISA KEVNot currently listed
Published2024-04-16
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
OpenFGA is a high-performance and flexible authorization/permission engine. Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs. You are very likely affected if your model involves exclusion (e.g. `a but not b`) or intersection (e.g. `a and b`). This vulnerability is fixed in v1.5.3.
Weakness classification
- security-advisories@github.com: CWE-863
Primary references
- security-advisories@github.com — Patch
- security-advisories@github.com — Patch, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Vendor Advisory