VULNERABILITY INTELLIGENCE
CVE-2024-28746
CVSS score8.1 HIGH
EPSS probability1.34%
CISA KEVNot currently listed
Published2024-03-14
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Description
Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access. Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability
Weakness classification
- security@apache.org: CWE-281
Primary references
- security@apache.org — Mailing List, Third Party Advisory
- security@apache.org — Patch
- security@apache.org — Mailing List, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Vendor Advisory