VULNERABILITY INTELLIGENCE
CVE-2024-25621
CVSS score7.3 HIGH
EPSS probability0.17%
CISA KEVNot currently listed
Published2025-11-06
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Description
containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.
Weakness classification
- security-advisories@github.com: CWE-279
Primary references
- security-advisories@github.com — Product
- security-advisories@github.com — Patch
- security-advisories@github.com — Patch, Vendor Advisory