VULNERABILITY INTELLIGENCE

CVE-2024-24773

CVSS score4.9 MEDIUM
EPSS probability0.78%
CISA KEVNot currently listed
Published2024-02-28
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N

Description

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-863
  • nvd@nist.gov: CWE-863

Primary references