VULNERABILITY INTELLIGENCE

CVE-2024-24772

CVSS score4.3 MEDIUM
EPSS probability0.95%
CISA KEVNot currently listed
Published2024-02-28
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Description

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Weakness classification

  • security@apache.org: CWE-89
  • nvd@nist.gov: CWE-89

Primary references