VULNERABILITY INTELLIGENCE
CVE-2024-24683
CVSS score6.5 MEDIUM
EPSS probability1.24%
CISA KEVNot currently listed
Published2024-03-19
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Description
Improper Input Validation vulnerability in Apache Hop Engine.This issue affects Apache Hop Engine: before 2.8.0. Users are recommended to upgrade to version 2.8.0, which fixes the issue. When Hop Server writes links to the PrepareExecutionPipelineServlet page one of the parameters provided to the user was not properly escaped. The variable not properly escaped is the "id", which is not directly accessible by users creating pipelines making the risk of exploiting this low. This issue only affects users using the Hop Server component and does not directly affect the client.
Weakness classification
- security@apache.org: CWE-20
Primary references
- security@apache.org — Mailing List, Third Party Advisory
- security@apache.org — Issue Tracking, Mailing List, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Issue Tracking, Mailing List, Vendor Advisory