VULNERABILITY INTELLIGENCE
CVE-2024-23841
CVSS score8.2 HIGH
EPSS probability0.39%
CISA KEVNot currently listed
Published2024-01-30
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Description
apollo-client-nextjs is the Apollo Client support for the Next.js App Router. The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this vulnerability, an attacker would need to either inject malicious input (e.g. by redirecting a user to a specifically-crafted link) or arrange to have malicious input be returned by a GraphQL server (e.g. by persisting it in a database). To fix this issue, please update to version 0.7.0 or later.
Weakness classification
- CWE-80: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
Primary references
- security-advisories@github.com — Patch
- security-advisories@github.com — Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Vendor Advisory