VULNERABILITY INTELLIGENCE
CVE-2024-23807
CVSS score9.8 CRITICAL
EPSS probability1.48%
CISA KEVNot currently listed
Published2024-02-29
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
The Apache Xerces C++ XML parser on versions 3.0.0 before 3.2.5 contains a use-after-free error triggered during the scanning of external DTDs. Users are recommended to upgrade to version 3.2.5 which fixes the issue, or mitigate the issue by disabling DTD processing. This can be accomplished via the DOM using a standard parser feature, or via SAX using the XERCES_DISABLE_DTD environment variable. This issue has been disclosed before as CVE-2018-1311, but unfortunately that advisory incorrectly stated the issue would be fixed in version 3.2.3 or 3.2.4.
Weakness classification
- security@apache.org: CWE-416
- 134c704f-9b21-4f2e-91b3-4a467353bcc0: CWE-416
Primary references
- security@apache.org — Exploit, Patch, Third Party Advisory
- security@apache.org — Mailing List, Patch, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Exploit, Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Patch, Vendor Advisory