VULNERABILITY INTELLIGENCE

CVE-2024-22371

CVSS score2.9 LOW
EPSS probability0.69%
CISA KEVNot currently listed
Published2024-02-26
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Description

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.

Weakness classification

  • 134c704f-9b21-4f2e-91b3-4a467353bcc0: CWE-922

Primary references