VULNERABILITY INTELLIGENCE

CVE-2024-13446

CVSS score9.8 CRITICAL
EPSS probability0.43%
CISA KEVNot currently listed
Published2025-03-12
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

The Workreap plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 3.2.5. This is due to the plugin not properly validating a user's identity prior to (1) performing a social auto-login or (2) updating their profile details (e.g. password). This makes it possible for unauthenticated attackers to (1) login as an arbitrary user if their email address is known or (2) change an arbitrary user's password, including administrators, and leverage that to gain access to their account. NOTE: This vulnerability was partially fixed in version 3.2.5.

Weakness classification

  • security@wordfence.com: CWE-288
  • nvd@nist.gov: NVD-CWE-Other

Primary references