VULNERABILITY INTELLIGENCE

CVE-2024-12213

CVSS score9.8 CRITICAL
EPSS probability0.66%
CISA KEVNot currently listed
Published2025-02-12
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

The WP Job Board Pro plugin for WordPress is vulnerable to privilege escalation in all versions up to 2.3.16. This is due to the plugin allowing a user to supply the 'role' field when registering. This makes it possible for unauthenticated attackers to register as an administrator on vulnerable sites. Please note that this may have been patched sooner, however, the oldest available version for us to confirm this is patched in was 1.2.85.

Weakness classification

  • CWE-266: Incorrect Privilege Assignment

Primary references