VULNERABILITY INTELLIGENCE

CVE-2024-12029

CVSS score9.8 CRITICAL
EPSS probability5.98%
CISA KEVNot currently listed
Published2025-03-20
Last modified2026-06-17
CVSS vectorCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3.

Weakness classification

  • security@huntr.dev: CWE-502

Primary references