VULNERABILITY INTELLIGENCE

CVE-2024-10909

CVSS score6.3 MEDIUM
EPSS probability0.46%
CISA KEVNot currently listed
Published2024-12-06
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Description

The The Pojo Forms plugin for WordPress is vulnerable to arbitrary shortcode execution via form_preview_shortcode AJAX action in all versions up to, and including, 1.4.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes. This was partially fixed in version 1.4.8.

Weakness classification

  • security@wordfence.com: CWE-94

Primary references