VULNERABILITY INTELLIGENCE
CVE-2023-7029
CVSS score6.4 MEDIUM
EPSS probability0.40%
CISA KEVNot currently listed
Published2024-02-05
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Description
The WordPress Button Plugin MaxButtons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to, and including 9.7.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially fixed in version 9.7.6.
Weakness classification
- security@wordfence.com: CWE-79
- nvd@nist.gov: CWE-79
Primary references
- security@wordfence.com — Issue Tracking
- security@wordfence.com — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Issue Tracking
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory