VULNERABILITY INTELLIGENCE

CVE-2023-6600

CVSS score8.6 HIGH
EPSS probability0.48%
CISA KEVNot currently listed
Published2024-01-03
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Description

The OMGF | GDPR/DSGVO Compliant, Faster Google Fonts. Easy. plugin for WordPress is vulnerable to unauthorized modification of data and Stored Cross-Site Scripting due to a missing capability check on the update_settings() function hooked via admin_init in all versions up to, and including, 5.7.9. This makes it possible for unauthenticated attackers to update the plugin's settings which can be used to inject Cross-Site Scripting payloads and delete entire directories. PLease note there were several attempted patched, and we consider 5.7.10 to be the most sufficiently patched.

Weakness classification

  • security@wordfence.com: CWE-862
  • nvd@nist.gov: CWE-79
  • 134c704f-9b21-4f2e-91b3-4a467353bcc0: CWE-79

Primary references