VULNERABILITY INTELLIGENCE

CVE-2023-49920

CVSS score6.5 MEDIUM
EPSS probability1.03%
CISA KEVNot currently listed
Published2023-12-21
Last modified2026-06-17

Description

Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected