VULNERABILITY INTELLIGENCE
CVE-2023-49295
CVSS score6.4 MEDIUM
EPSS probability1.20%
CISA KEVNot currently listed
Published2024-01-10
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:H
Description
quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.
Weakness classification
- security-advisories@github.com: CWE-400
Primary references
- security-advisories@github.com — Patch
- security-advisories@github.com — Patch
- security-advisories@github.com — Patch
- security-advisories@github.com — Patch
- security-advisories@github.com — Patch
- security-advisories@github.com — Patch
- security-advisories@github.com — Patch
- security-advisories@github.com — Patch
- security-advisories@github.com — Vendor Advisory
- security-advisories@github.com
- security-advisories@github.com
- af854a3a-2127-422b-91ae-364da2661108 — Patch