VULNERABILITY INTELLIGENCE
CVE-2023-4919
CVSS score6.4 MEDIUM
EPSS probability0.60%
CISA KEVNot currently listed
Published2023-10-20
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Description
The iframe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `iframe` shortcode in versions up to, and including, 4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permission and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 4.6 and fully patched in version 4.7.
Weakness classification
- security@wordfence.com: CWE-79
- nvd@nist.gov: CWE-79
Primary references
- security@wordfence.com — Exploit
- security@wordfence.com — Exploit
- security@wordfence.com — Patch
- security@wordfence.com — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Exploit
- af854a3a-2127-422b-91ae-364da2661108 — Exploit
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory