VULNERABILITY INTELLIGENCE
CVE-2023-4599
CVSS score6.4 MEDIUM
EPSS probability0.52%
CISA KEVNot currently listed
Published2023-08-30
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Description
The Email Encoder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'eeb_mailto' shortcode in versions up to, and including, 2.1.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A partial patch was issued in version 2.1.8. The vulnerability was fully patched in 2.1.9.
Weakness classification
- CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Primary references
- security@wordfence.com — Product
- security@wordfence.com — Product
- security@wordfence.com
- security@wordfence.com — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Product
- af854a3a-2127-422b-91ae-364da2661108 — Product
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory