VULNERABILITY INTELLIGENCE
CVE-2023-43826
CVSS score7.5 HIGH
EPSS probability0.89%
CISA KEVNot currently listed
Published2023-12-19
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.
Weakness classification
- security@apache.org: CWE-190
Primary references
- security@apache.org — Mailing List, Third Party Advisory
- security@apache.org — Mailing List, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Vendor Advisory