VULNERABILITY INTELLIGENCE

CVE-2023-43701

CVSS score4.3 MEDIUM
EPSS probability1.00%
CISA KEVNot currently listed
Published2023-11-27
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Description

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2.  Users are recommended to upgrade to version 2.1.2, which fixes this issue.

Weakness classification

  • security@apache.org: CWE-79

Primary references