VULNERABILITY INTELLIGENCE

CVE-2023-42780

CVSS score6.5 MEDIUM
EPSS probability1.44%
CISA KEVNot currently listed
Published2023-10-14
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Description

Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dag_ids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

Weakness classification

  • security@apache.org: CWE-200

Primary references