VULNERABILITY INTELLIGENCE
CVE-2023-39441
CVSS score5.9 MEDIUM
EPSS probability0.80%
CISA KEVNot currently listed
Published2023-08-23
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Description
Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate. Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability
Weakness classification
- security@apache.org: CWE-295
Primary references
- security@apache.org — Mailing List, Patch, Third Party Advisory
- security@apache.org — Patch
- security@apache.org — Patch
- security@apache.org — Patch
- security@apache.org — Mailing List, Patch, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Patch, Vendor Advisory