VULNERABILITY INTELLIGENCE
CVE-2023-35005
CVSS score6.5 MEDIUM
EPSS probability1.53%
CISA KEVNot currently listed
Published2023-06-19
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Description
In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations. This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive. This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.
Weakness classification
- CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
Primary references
- security@apache.org — Patch
- security@apache.org — Issue Tracking
- security@apache.org — Mailing List, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Issue Tracking
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Vendor Advisory