VULNERABILITY INTELLIGENCE

CVE-2023-37582

CVSS score9.8 CRITICAL
EPSS probability96.57%
CISA KEVKnown exploited vulnerability
Published2023-07-12
Last modified2026-06-17

Known Exploited Vulnerability

Apache RocketMQ Command Execution Vulnerability

Vendor / product: Apache / RocketMQ

Description

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .