VULNERABILITY INTELLIGENCE
CVE-2023-31098
CVSS score9.8 CRITICAL
EPSS probability1.23%
CISA KEVNot currently listed
Published2023-05-22
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Weak Password Requirements vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.1.0 through 1.6.0. When users change their password to a simple password (with any character or symbol), attackers can easily guess the user's password and access the account. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7805 https://github.com/apache/inlong/pull/7805 to solve it.
Weakness classification
- security@apache.org: CWE-521
- nvd@nist.gov: CWE-521
Primary references
- security@apache.org — Mailing List, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Vendor Advisory