VULNERABILITY INTELLIGENCE
CVE-2023-31039
CVSS score9.8 CRITICAL
EPSS probability1.52%
CISA KEVNot currently listed
Published2023-05-08
Last modified2026-10-24
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Security vulnerability in Apache bRPC <1.5.0 on all platforms allows attackers to execute arbitrary code via ServerOptions::pid_file. An attacker that can influence the ServerOptions pid_file parameter with which the bRPC server is started can execute arbitrary code with the permissions of the bRPC process. Solution: 1. upgrade to bRPC >= 1.5.0, download link: https://dist.apache.org/repos/dist/release/brpc/1.5.0/ https://dist.apache.org/repos/dist/release/brpc/1.5.0/ 2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch: https://github.com/apache/brpc/pull/2218 https://github.com/apache/brpc/pull/2218
Weakness classification
- security@apache.org: CWE-20
Primary references
- security@apache.org — Mailing List, Patch, Third Party Advisory
- security@apache.org — Mailing List, Patch, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Mailing List, Patch, Vendor Advisory