VULNERABILITY INTELLIGENCE
CVE-2023-28095
CVSS score7.5 HIGH
EPSS probability0.97%
CISA KEVNot currently listed
Published2023-03-15
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.1.7 and 3.2.4 have a potential issue in `msg_translator.c:2628` which might lead to a server crash. This issue was found while fuzzing the function `build_res_buf_from_sip_req` but could not be reproduced against a running instance of OpenSIPS. This issue could not be exploited against a running instance of OpenSIPS since no public function was found to make use of this vulnerable code. Even in the case of exploitation through unknown vectors, it is highly unlikely that this issue would lead to anything other than Denial of Service. This issue has been fixed in versions 3.1.7 and 3.2.4.
Weakness classification
- security-advisories@github.com: CWE-20
- nvd@nist.gov: NVD-CWE-noinfo
Primary references
- security-advisories@github.com — Patch, Third Party Advisory
- security-advisories@github.com — Third Party Advisory
- security-advisories@github.com — Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Vendor Advisory