VULNERABILITY INTELLIGENCE

CVE-2023-25565

CVSS score7.5 HIGH
EPSS probability1.10%
CISA KEVNot currently listed
Published2023-02-14
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, an incorrect free when decoding target information can trigger a denial of service. The error condition incorrectly assumes the `cb` and `sh` buffers contain a copy of the data that needs to be freed. However, that is not the case. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This will likely trigger an assertion failure in `free`, causing a denial-of-service. This issue is fixed in version 1.2.0.

Weakness classification

  • security-advisories@github.com: CWE-590
  • nvd@nist.gov: CWE-763

Primary references