VULNERABILITY INTELLIGENCE

CVE-2023-25141

CVSS score7.5 HIGH
EPSS probability1.16%
CISA KEVNot currently listed
Published2023-02-14
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI. Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.

Weakness classification

  • security@apache.org: CWE-74
  • 134c704f-9b21-4f2e-91b3-4a467353bcc0: CWE-74

Primary references