VULNERABILITY INTELLIGENCE
CVE-2023-2301
CVSS score6.1 MEDIUM
EPSS probability0.29%
CISA KEVNot currently listed
Published2023-06-03
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
The Contact Form Builder by vcita plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.10.3. This is due to missing nonce validation on the ls_parse_vcita_callback function. This makes it possible for unauthenticated attackers to modify the plugin's settings and inject malicious JavaScript via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. While the Cross-Site Scripting issue was patched in version 4.10.1, the plugin is still technically vulnerable to Cross-Site Request Forgery since a capability check but no nonce check was added in 4.10.2.
Weakness classification
- security@wordfence.com: CWE-352
- nvd@nist.gov: CWE-352
Primary references
- security@wordfence.com — Third Party Advisory
- security@wordfence.com — Patch
- security@wordfence.com
- security@wordfence.com — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory