VULNERABILITY INTELLIGENCE
CVE-2023-2279
CVSS score5.4 MEDIUM
EPSS probability0.29%
CISA KEVNot currently listed
Published2023-08-31
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
Description
The WP Directory Kit plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.1. This is due to missing or incorrect nonce validation on the 'admin_page_display' function. This makes it possible for unauthenticated attackers to delete or change plugin settings, import demo data, modify or delete Directory Kit related posts and terms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Partial patches were made avilable in versions 1.2.0 and 1.2.1 but the issue was not fully patched until 1.2.2
Weakness classification
- security@wordfence.com: CWE-352
Primary references
- security@wordfence.com — Product
- security@wordfence.com — Patch
- security@wordfence.com — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Product
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory