VULNERABILITY INTELLIGENCE
CVE-2023-22468
CVSS score8.8 HIGH
EPSS probability0.50%
CISA KEVNot currently listed
Published2023-01-26
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Description
Discourse is an open source platform for community discussion. Versions prior to 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed), are vulnerable to cross-site Scripting. A maliciously crafted URL can be included in a post to carry out cross-site scripting attacks on sites with disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. This vulnerability is patched in versions 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed). As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse.
Weakness classification
- security-advisories@github.com: CWE-79
Primary references
- security-advisories@github.com — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory