VULNERABILITY INTELLIGENCE
CVE-2023-20873
CVSS score9.8 CRITICAL
EPSS probability1.12%
CISA KEVNot currently listed
Published2023-04-20
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
Weakness classification
- nvd@nist.gov: NVD-CWE-noinfo
Primary references
- security@vmware.com — Third Party Advisory
- security@vmware.com
- security@vmware.com — Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108
- af854a3a-2127-422b-91ae-364da2661108 — Vendor Advisory