VULNERABILITY INTELLIGENCE

CVE-2022-44645

CVSS score8.8 HIGH
EPSS probability1.93%
CISA KEVNot currently listed
Published2023-01-31
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.

Weakness classification

  • security@apache.org: CWE-502

Primary references