VULNERABILITY INTELLIGENCE

CVE-2022-39284

CVSS score2.6 LOW
EPSS probability1.12%
CISA KEVNot currently listed
Published2022-10-06
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N

Description

CodeIgniter is a PHP full-stack web framework. In versions prior to 4.2.7 setting `$secure` or `$httponly` value to `true` in `Config\Cookie` is not reflected in `set_cookie()` or `Response::setCookie()`. As a result cookie values are erroneously exposed to scripts. It should be noted that this vulnerability does not affect session cookies. Users are advised to upgrade to v4.2.7 or later. Users unable to upgrade are advised to manually construct their cookies either by setting the options in code or by constructing Cookie objects. Examples of each workaround are available in the linked GHSA.

Weakness classification

  • CWE-665: Improper Initialization
  • CWE-732: Incorrect Permission Assignment for Critical Resource

Primary references