VULNERABILITY INTELLIGENCE

CVE-2022-37023

CVSS score6.5 MEDIUM
EPSS probability1.78%
CISA KEVNot currently listed
Published2022-08-31
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Description

Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.

Weakness classification

  • security@apache.org: CWE-502
  • nvd@nist.gov: CWE-502

Primary references