VULNERABILITY INTELLIGENCE

CVE-2022-31158

CVSS score7.5 HIGH
EPSS probability0.86%
CISA KEVNot currently listed
Published2022-07-15
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Description

LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.

Weakness classification

  • security-advisories@github.com: CWE-294
  • nvd@nist.gov: CWE-294

Primary references