VULNERABILITY INTELLIGENCE
CVE-2022-31147
CVSS score7.5 HIGH
EPSS probability2.24%
CISA KEVNot currently listed
Published2022-07-14
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.
Weakness classification
- security-advisories@github.com: CWE-1333
- nvd@nist.gov: CWE-1333
Primary references
- security-advisories@github.com — Patch, Third Party Advisory
- security-advisories@github.com — Release Notes, Third Party Advisory
- security-advisories@github.com — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Release Notes, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory