VULNERABILITY INTELLIGENCE
CVE-2022-31106
CVSS score8.3 HIGH
EPSS probability1.05%
CISA KEVNot currently listed
Published2022-06-28
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L
Description
Underscore.deep is a collection of Underscore mixins that operate on nested objects. Versions of `underscore.deep` prior to version 0.5.3 are vulnerable to a prototype pollution vulnerability. An attacker can craft a malicious payload and pass it to `deepFromFlat`, which would pollute any future Objects created. Any users that have `deepFromFlat` or `deepPick` (due to its dependency on `deepFromFlat`) in their code should upgrade to version 0.5.3 as soon as possible. Users unable to upgrade may mitigate this issue by modifying `deepFromFlat` to prevent specific keywords which will prevent this from happening.
Weakness classification
- security-advisories@github.com: CWE-915
- nvd@nist.gov: CWE-1321
Primary references
- security-advisories@github.com — Patch, Third Party Advisory
- security-advisories@github.com — Exploit, Issue Tracking, Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Exploit, Issue Tracking, Patch, Third Party Advisory