VULNERABILITY INTELLIGENCE
CVE-2022-24775
CVSS score7.5 HIGH
EPSS probability2.48%
CISA KEVNot currently listed
Published2022-03-21
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.
Weakness classification
- CWE-20: Improper Input Validation
Primary references
- security-advisories@github.com — Patch, Third Party Advisory
- security-advisories@github.com — Patch, Third Party Advisory
- security-advisories@github.com — Third Party Advisory
- security-advisories@github.com — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory