VULNERABILITY INTELLIGENCE

CVE-2022-21647

CVSS score7.7 HIGH
EPSS probability37.67%
CISA KEVNot currently listed
Published2022-01-04
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:H

Description

CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.

Weakness classification

  • security-advisories@github.com: CWE-502
  • nvd@nist.gov: CWE-502

Primary references