VULNERABILITY INTELLIGENCE
CVE-2021-4428
CVSS score2.7 LOW
EPSS probability15.81%
CISA KEVNot currently listed
Published2023-07-18
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
Description
A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.
Weakness classification
- cna@vuldb.com: CWE-200
Primary references
- cna@vuldb.com — Patch
- cna@vuldb.com — Patch, Vendor Advisory
- cna@vuldb.com — Release Notes
- cna@vuldb.com — Permissions Required
- cna@vuldb.com — Permissions Required
- af854a3a-2127-422b-91ae-364da2661108 — Patch
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Vendor Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Release Notes
- af854a3a-2127-422b-91ae-364da2661108 — Permissions Required
- af854a3a-2127-422b-91ae-364da2661108 — Permissions Required