VULNERABILITY INTELLIGENCE

CVE-2021-41265

CVSS score8.1 HIGH
EPSS probability1.32%
CISA KEVNot currently listed
Published2021-12-09
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Description

Flask-AppBuilder is a development framework built on top of Flask. Verions prior to 3.3.4 contain an improper authentication vulnerability in the REST API. The issue allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. This only affects non database authentication types and new REST API endpoints. Users should upgrade to Flask-AppBuilder 3.3.4 to receive a patch.

Weakness classification

  • security-advisories@github.com: CWE-287

Primary references