VULNERABILITY INTELLIGENCE

CVE-2021-41165

CVSS score8.2 HIGH
EPSS probability1.57%
CISA KEVNot currently listed
Published2021-11-17
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L

Description

CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Weakness classification

  • security-advisories@github.com: CWE-79
  • nvd@nist.gov: CWE-79

Primary references