VULNERABILITY INTELLIGENCE

CVE-2021-41164

CVSS score8.2 HIGH
EPSS probability1.35%
CISA KEVNot currently listed
Published2021-11-17
Last modified2026-08-25
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L

Description

CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Weakness classification

  • security-advisories@github.com: CWE-79
  • nvd@nist.gov: CWE-79

Primary references