VULNERABILITY INTELLIGENCE
CVE-2021-38153
CVSS score5.9 MEDIUM
EPSS probability6.20%
CISA KEVNot currently listed
Published2021-09-22
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Description
Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.
Weakness classification
- security@apache.org: CWE-203
- nvd@nist.gov: CWE-203
Primary references
- security@apache.org — Vendor Advisory
- security@apache.org
- security@apache.org
- security@apache.org
- security@apache.org
- security@apache.org
- security@apache.org
- security@apache.org
- security@apache.org — Patch, Third Party Advisory
- security@apache.org — Third Party Advisory
- security@apache.org — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Vendor Advisory