VULNERABILITY INTELLIGENCE

CVE-2021-33036

CVSS score8.8 HIGH
EPSS probability3.97%
CISA KEVNot currently listed
Published2022-06-15
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Weakness classification

  • security@apache.org: CWE-24
  • nvd@nist.gov: CWE-22

Primary references