VULNERABILITY INTELLIGENCE
CVE-2021-32702
CVSS score8 HIGH
EPSS probability1.40%
CISA KEVNot currently listed
Published2021-06-25
Last modified2026-06-17
CVSS vectorCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.
Weakness classification
- security-advisories@github.com: CWE-79
- nvd@nist.gov: CWE-79
Primary references
- security-advisories@github.com — Patch, Third Party Advisory
- security-advisories@github.com — Third Party Advisory
- security-advisories@github.com
- af854a3a-2127-422b-91ae-364da2661108 — Patch, Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108 — Third Party Advisory
- af854a3a-2127-422b-91ae-364da2661108